Astro Professional Gaming Headsets & Bags

Astro Global

Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Astro A40 PC Set Up - Another Issue

  1. #1
    Join Date
    Jan 2010
    Posts
    22

    Default Astro A40 PC Set Up - Another Issue

    Astro A40 Wireless 5.8 Mixamp.
    OS: Windows 7 64 bit
    Sound Card: HT Omega Striker 7.1 - Drivers up to date

    Connections as follows:
    MixAmp TX base via optical cable to HT Omega
    MixAmp TX PC voice cable to PC USB
    MixAmp RX to headsets

    All correct and working with sound to the headsets.

    Now here is the new issue. When connecting the PC chat cable via the USB -- it disabled the sound back into the headsets and formed a new "astro chat" option. This option needs to be disabled in order to hear anything coming out of the HT omega.

    Even when the Astro Chat is enabled -- still no sound heard through the mic.

    I am getting VERY frustrated with this PC set up and have spent a ton of money on what is a VERY backwards system. Only success with CHAT and SOUND has been via direct usb connection to the motherboard and NO optical out cable. I have a feeling -- that I need to adapt the USB PC cable to turn it into a 2 jack set up for the HT omega mic. But thats just me spitballing.

    Any ideas? I have checked the hardware set up a million times. It is all correct and all drivers are up to date. Any ideas with regard to software mic configure for the chat?

  2. #2
    Join Date
    Mar 2010
    Location
    Wood Vilage, Oregon
    Posts
    9,692

    Default

    Might have to change the bios so the onboard sound will let the
    Mic work?

  3. #3
    Join Date
    Dec 2009
    Location
    England, United Kingdom
    Posts
    17,021

    Default

    Sounds like Windows 7 is setting the ASTRO Chat to the default speaker setup.

    Try this.

    On your Windows Superbar, next to the clock there should be a speaker icon. Right click on it and click Playback Devices. Click on your speakers/sound card and then select Set Default at the bottom. This will tell Windows that the sound card is going to be the default playback device, even if you plug in the USB Chat Cable.

    Then go to the Recording tab (located on the same Window above all the devices), select ASTRO Chat and then select set default.

    You should be all good to go then.

    - AllTimeMitch
    Last edited by ASTRO Vertigo; 01-22-2011 at 01:15 PM.

    ASTRO Gaming Forum Moderator
    Open A Support Case |
    ASTRO Gaming US/UK Support | ASTRO Gaming France Support |
    Contact Me | Send me a private message | Send me an email |


  4. #4
    Join Date
    Jan 2010
    Posts
    22

    Default

    Playback tab --
    (options)
    ATI HDMI Output
    ATI HDMI Output
    Speakers (HTO Striker 7.1) Default device

    Recording tab --
    (options)
    Microphone (astro chat) Default Device
    CD Player (HTO striker) -- ready
    Line In (HTO striker) -- ready
    SPDIF In (HTO stiker) - unavail
    Aux (7.1 Striker) - unavail
    Stereo Mix (7.1 Striker) - unavail

    Nada. I think this is an issue with optical in and USB device out. I will try the bios idea now but not sure how it is going to work -- because basically you are using two different devices to run the 'same' tasks.

    Does anyone have a working PC with the Wireless Astro A40s and an optical out?

  5. #5
    Join Date
    Mar 2010
    Posts
    8,099

    Default

    Quote Originally Posted by Vymm View Post
    Playback tab --
    (options)
    ATI HDMI Output
    ATI HDMI Output
    Speakers (HTO Striker 7.1) Default device

    Recording tab --
    (options)
    Microphone (astro chat) Default Device
    CD Player (HTO striker) -- ready
    Line In (HTO striker) -- ready
    SPDIF In (HTO stiker) - unavail
    Aux (7.1 Striker) - unavail
    Stereo Mix (7.1 Striker) - unavail

    Nada. I think this is an issue with optical in and USB device out. I will try the bios idea now but not sure how it is going to work -- because basically you are using two different devices to run the 'same' tasks.

    Does anyone have a working PC with the Wireless Astro A40s and an optical out?
    You didn't finish it all. Click the Microphone (Astro Chat) and go down to properties
    On the popup window go to the listen tab and click the tick box "Listen to this Device".


  6. #6
    Join Date
    Jan 2010
    Posts
    22

    Default

    There also used to be a 7.1 Striker DEVICE in the sound playback options but that is no longer there.

    I also verifed that all drivers are up to date on all of the sound devices.

    In the HT OMEGA Xgear 3D sfotware:

    Set to 2 Channel with 7.1 virutal, EX Xear 3d, DTS Neo:PC

    Dolby Digital Live slected, headphones and digital audio 44.1 KHz

    Under REC SPDIF selected. Other options there are CD Player, Aux, Stero Mix and Line In. (I was thinking AUX since the MixAmp says Aux but didnt have success with that either)

    Karaoke is turned off.

    Effect Generic.

  7. #7
    Join Date
    Mar 2010
    Posts
    8,099

    Default

    On your system tray click the little icon that says Xear 3D and make sure S/PDIF output is set and that Dolby Digital Live is set in the pull down menu.


  8. #8
    Join Date
    Jan 2010
    Posts
    22

    Default

    Quote Originally Posted by AcIdC0R3 View Post
    On your system tray click the little icon that says Xear 3D and make sure S/PDIF output is set and that Dolby Digital Live is set in the pull down menu.
    In my post above yours... I mentioned DDL is selected. Thank you for trying to assist.

    Also when I select listen to device -- I hear feedback. However I cannot get the mic to register anything going out over ventrilo.
    Last edited by Vymm; 01-22-2011 at 01:55 PM.

  9. #9
    Join Date
    Mar 2010
    Posts
    8,099

    Default

    Quote Originally Posted by Vymm View Post
    In my post above yours... I mentioned DDL is selected. Thank you for trying to assist.
    Yeah OK. Hrm... You've tried all that and still no sound. I would at this point contact the Support Team and let them assist you with this. I think we've helped you all we could. It could be any number of things that's having the issues.

    No worries though. They'll have you fixed up.


  10. #10
    Join Date
    Jan 2010
    Posts
    22

    Default

    Contacted the support team. Awaiting a response I will let you know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •