Astro Professional Gaming Headsets & Bags

Astro Global

Results 1 to 8 of 8

Thread: Custom astro a40 tags

  1. #1
    Join Date
    Feb 2013
    Posts
    4

    Default Custom astro a40 tags

    Well because for whatever reason I can't post anywhere else but here I will have to. I purchased a set of the 3 Astro A40 custom tags for my headset, submitted the images I wanted to use and all was approved. The issue lies in the merchandise that I received, I could not be more upset at the waste of money at this point. The tags are not printed correctly, the designs are not even printed all the way across the tags and there are white ink/paint lines at the bottom of each tag.

    So I opened a support ticket about the issue thinking that it would get resolved. Weeks have passed and no response, so I opened another ticket and yet again no response. Now the tickets have auto times out and closed without a response at ll from Astro, either they don't care about customer service or no one works there anymore. I am forced to dispute the charges at this point because the custom tags are terrible and not what I paid for And astro refuses to respond to support tickets trying to resolve this issue. Hopefully someone at astro reads these forums and responds to me, because they definitely do not pay any attention to support tickets.

  2. #2
    Join Date
    Dec 2009
    Location
    England, United Kingdom
    Posts
    16,856

    Default

    Hi Adams006,

    Could you post your support case numbers on this thread and I will have a member from the support team review them as soon as possible. Also if possible, I would suggest to take a picture of the problem and upload it to a website such as www.imgur.com so our support team can take a look.

    - Mitchell

    ASTRO Gaming Forum Moderator
    Open A Support Case |
    ASTRO Gaming US/UK Support | ASTRO Gaming France Support |
    Contact Me | Send me a private message | Send me an email |


  3. #3
    Join Date
    Feb 2013
    Posts
    4

    Default

    Case # 00153320

    Remember though that I was forced to open this case # today because the previous 2 I opened went unanswered and were auto closed with no response from Astro support. I have pics taken and need to upload them, but I am not going to waste my time on doing so until someone reply's to me first. Thank you for your reply.


    here are the original cases
    CASE #00148099 Has allot of info

    CASE #00151019

    Both of these were closed with no response.
    Last edited by Adams006; 02-11-2013 at 02:24 PM.

  4. #4
    Join Date
    Dec 2009
    Location
    England, United Kingdom
    Posts
    16,856

    Default

    Hi Adams006,

    I've forwarded your cases to be merged, opened and responded to as quickly as possible. I would suggest to not open up more support cases and to keep with your original from this point on.

    Thanks,
    - Mitchell

    ASTRO Gaming Forum Moderator
    Open A Support Case |
    ASTRO Gaming US/UK Support | ASTRO Gaming France Support |
    Contact Me | Send me a private message | Send me an email |


  5. #5
    Join Date
    Feb 2013
    Posts
    4

    Default

    After almost 2 months of trying to get help from Astro support it took me coming here to publically complain to get any help. The best part is that i did not actually get any help. I submitted my ticket and even provided images of the poor quality print on my customized astro a40 tags. I showed how there is a white paint line along the bottom of all 3 tags that should not be there and also how the image on all 3 tags was not printed all the way across the tags but instead cut off short on the right side of all 3 leaving a black line. The best part is the response that I received was that the images were printed perfectly??? that is not possible, but if astro support claims that then every custom tag image they use on there website is printed wrong because if mine are perfect i would hate to see what is printed wrong.

    So they refused any support, so now I have to dispute the charges and take my case to forums and blogs to represent the terrible support or total lack of support they give once they have your money. I will link some ingur images og my tags to prove they are not printed perfectly.

    http://imgur.com/MVg3oaL

    http://imgur.com/6CxuzzX

    http://imgur.com/mXPQgZA

    http://imgur.com/2cGy97l

    http://imgur.com/fXcyk9p

    ALl I wanted was new tags printed properly, I never even asked for a refund. Now I am forced to dispute the charges because Astro will do nothing, and the claim that they are perfect is so far from the truth that I cant see how anyone would reply to me that they are in fact perfect.

  6. #6
    Join Date
    Dec 2009
    Location
    England, United Kingdom
    Posts
    16,856

    Default

    Hi Adams006,

    If our support team have checked the images against the one's you've uploaded and they appear to be correct, there is nothing I can do over the forum to reverse this decision made.

    Sorry about this.

    - Mitchell

    ASTRO Gaming Forum Moderator
    Open A Support Case |
    ASTRO Gaming US/UK Support | ASTRO Gaming France Support |
    Contact Me | Send me a private message | Send me an email |


  7. #7
    Join Date
    Feb 2013
    Posts
    4

    Default

    they did not check them against what i sent to be printed, they simply said that the images of the printed tags i sent were tags printed perfectly. When i dispute the charges i will provide the image i sent to compare against what was actually printed and sent to me.

  8. #8
    Join Date
    Mar 2013
    Location
    Germany
    Posts
    5

    Default

    Hi Adams006,

    i don't think the problem here is with Astro's printing procedure, but with the Tag Customizer Application itself.

    I tried my hand at making myself a custom set of tags earlier, but when i uploaded them to the Beta..



    As you can see, my preview showed those white lines that you got on your finished tags too.

    But that's the thing. Those lines already show up on the preview. I don't know if they did for you too, but as you can see they did for me.

    Let me just make a guess.. You took those images straight off the internet, saved them onto your computer and used them in the application?
    If so, i suggest you download the template at the top right of the customizer for your next try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •