Astro Professional Gaming Headsets & Bags

Astro Global

Page 1 of 6 123 ... LastLast
Results 1 to 10 of 60

Thread: [ACGG Post] PC Configuration Tutorial

  1. #1
    Join Date
    Dec 2012
    Posts
    27

    Smile [ACGG Post] PC Configuration Tutorial

    [Please Note, this Post is part of the ASTRO Community Gaming Group and is used strictly for information. In no way does ASTRO specifically endorse any particular product or company, but included are suggestions of some available products out on the market that have been made by our Community. -ASTRO refraxion]

    Hey Everyone! I've found that there are too many posts looking for guidance on the correct way to setup the Astro A40's with a PC - and unfortunately, the answers are scattered all over the place. I've combined them all here into one cohesive tutorial. Use this to configure your A40's properly on PC. All the information included here was obtained by self trial and error and answers I obtained on the forums from Astro Community Leaders, Moderators and users. Hope this helps


    How to set up your Astro A40's with your PC and what you'll need

    To get your headset working, you must provide it with power via the included USB Cable. If you want surround sound (which you probably do) you will need to connect your Mixamp via an optical cable to a sound card or onboard sound/motherboard (mobo) in your PC. That sound card/mobo MUST support Dolby Digital Live. If it does not, your headset will only get stereo sound. The port on the back of the Mixamp is for Mini Toslink (which looks like a black plastic needle nosed 3.5mm headphone jack). Depending on what type of S/PDIF port you have on your soundcard, you may need this type of cable or this kind of adapter in order to hook up your mixamp properly. Once it's all connected, turn the mixamp on. Windows should recognize the mixamp and tell you its working properly. Find and turn on DDL (Dolby Digital Live) in your sound cards hardware and/or software settings. In your sound settings, select your "Speakers" as your default device and your "Mixamp" as your default communications device. Right click on your speakers, configure them to 5.1 and then hit "test". You should hear 5 directional prompts plus a subwoofer hit. You're good to go!

    How does ASTRO's surround sound work?

    TOSLINK Optical only has enough bandwidth to carry Dolby Digital 5.1 audio (not 7.1). The Astro MixAmp utilizes Dolby Pro Logic hardware which enables the mixamp to create two extra channels virtually, on the fly, for simulated 7.1 Surround Sound. If you are using TOSLINK Optical out (with DDL) as your output method, then you are literally bypassing your sound card, turning it into a passthrough device. No matter what type of sound card you have, there will be almost NO difference (minus the EQ settings each company hosts) in sound quality when using your headphones through the Mixamp. The only time you WILL hear a difference in audio quality (between expensive and cheap sound cards) is by plugging headphones/speakers directly into your sound card (bypassing the mixamp completely) and playing audio that way.
    And no, theres no real way to make sure 7.1 is 'on'. The Mixamp is just doing it as it goes."

    In other words, if you're using Astro A40s/50s - you live in a world of 5.1. Your card outputs 5.1, you should set your computer and game settings to 5.1 - and then let the Mixamp do the rest (upscale to 7.1 on its own).

    My onboard sound doesn't support DDL. What kind of sound card should I get?

    Based on popular feedback from the forums, these cards are the one's that come most recommended. However, any sound card that supports DDL will work fine.

    ASUS Xonar DX
    ASUS Xonar Essence STX
    Creative Sound Blaster Recon3D PCIe
    Omega Striker 7.1 (discontinued in most stores now)
    Sound Blaster X-Fi Titanium HD

    Once I get a sound card connected and everything is set up, what should I turn on in the software that came with my card? EQs, bass enhancement, Crystalizer...etc?

    Ideally, nothing. According to Astro, the Mixamp works best when being given the most pure form of sound from your computer. With the new 2013 edition Astro's there are 4 EQ modes built in to choose from that are professionally mixed and tailored to different styles of play.

    - Pro (used in competitive gaming to hear more acute directional audio. ie, footsteps etc)
    - Core (used in singleplayer gaming to hear the game the way the developer intended)
    - Media (used for listing to music and movies)
    - Sports (used while playing sports games)

    In summary, if there are any settings in your sound card to "enhance" things - you'll most likely get better sound by turning them all off and letting the Mixamp do the work for you!

    In addition, here is a sweet video guide made by forum user BioSpark!


    Note: Mic issue described here has been fixed by the latest firmware udpate! -ASTRO refraxion (05/06/13)
    Last edited by Valfrost; 12-29-2012 at 05:32 PM.

  2. #2

    Default

    EDITED : I have DDL enabled. Still, if I right click on my "speaker" or in my case "Realtek high Definition Audio" and click test I can only hear 2 prompts.

    Instead, if I right click on it, go under Properties, click the "Supported Formats" tab, click on "Dolby Digital" and test it from there, I can hear the 5 prompts + sub prompt. So I guess I'm good?
    Last edited by PinealoGIK_; 12-29-2012 at 12:59 PM.

  3. #3
    Join Date
    Dec 2012
    Posts
    27

    Default

    Is there somewhere in your Speaker settings where it allows you to set 2.1, 5.1 etc? If there is, make sure its set to 5.1 by default so that you're not taking any chances. Also make sure the Dolby button on your mixamp is on.

    With that said, if you can hear the 5 prompts + sub prompt AND they sound like they are coming from those directions - then you should be good to go. Just boot up a game, make sure 5.1 is selected in-game (if the option is available), if not the game will most likely default to this and try the headset out. Find some source of audio thats constant (like a waterfall, fire pit) and then rotate around and see if your headset is matching the direction.
    Last edited by Valfrost; 12-29-2012 at 01:15 PM.

  4. #4

    Default

    I tried with Dark Soul and Planetside 2, sounds direction seems to be working fine with DDL enabled and all that stuff. Thank you good sir.

    Also, if I may ask, what exactly does the "Dolby" button do on the mixamp? When it's on, explosion or loud noise aren't as loud (they sounds kinda of "muffled" with some sort of added bass, hard to explain, it doesn't sounds bad at all, just very different). Might just be me thou, I don't know.
    Last edited by PinealoGIK_; 12-29-2012 at 01:59 PM.

  5. #5
    Join Date
    Dec 2012
    Posts
    27

    Default

    The Dolby button is what turns on surround sound. With it off, you're only hearing stereo sound. As for it sounding "different", that might be because its the first time your ears are hearing 7.1 in a headset before. It was the same case with me. Think of the sound space this way - the Mixamp is trying to position you in the middle of a living room that has a 7.1 surround theater playing. Its giving every sound around you some atmosphere (EQ'ing/small amount of reverb) so it sounds like your actually standing in that space whether its inside a cramped dungeon or outside in the middle of a open field. With stereo, you're probably used to sound being a bit more 'sharp' and acute all the time - no matter the distance (keep in mind, some people prefer this). With the Astro's, sounds breath a little more to sound like they're really coming from a specific distance. Dunno if I'm explaining this well, but leave the Dolby button on for awhile and try getting used to it. If you're like me, after awhile you'll have a hard time playing with it off. It really does make a huge difference IMO.

    NOTE: It shouldn't sound TOO echoey. I ran into that issue when I first set up my headset. Sounds were coming from the correct directions, but everything sounded like I was in a tin can. Turned out my DDL wasn't on and I wasnt getting all my sound prompts. Once I turned that on and got all 5 prompts + sub prompt, then it all sounded great.
    Last edited by Valfrost; 12-29-2012 at 02:53 PM.

  6. #6
    Join Date
    Nov 2012
    Posts
    14

    Default

    Video is featured above.
    Last edited by BioSpark; 12-29-2012 at 05:32 PM.

  7. #7
    Join Date
    Dec 2012
    Posts
    27

    Default

    Yeah it is.
    Last edited by Valfrost; 12-29-2012 at 05:59 PM.

  8. #8

    Default

    Thanks, you guys are awesome.

  9. #9
    Join Date
    Nov 2012
    Posts
    14

    Default

    Quote Originally Posted by PinealoGIK_ View Post
    Thanks, you guys are awesome.
    No prob!

  10. #10
    Join Date
    Dec 2012
    Posts
    10

    Default

    Quote Originally Posted by PinealoGIK_ View Post
    EDITED : I have DDL enabled. Still, if I right click on my "speaker" or in my case "Realtek high Definition Audio" and click test I can only hear 2 prompts.

    Instead, if I right click on it, go under Properties, click the "Supported Formats" tab, click on "Dolby Digital" and test it from there, I can hear the 5 prompts + sub prompt. So I guess I'm good?
    Hi, I bought the Astro A40 and Mixamp today and have it setup but I thought the sounds had a lot of echo and reverb to it. Therefore I came to this forum to see if I have the system setup properly. I have on board sound with the Realtek HD Audio. I have the optical connection connected to the Mixamp and in my sound setting this is the default comms device. In supported formats I have DTS and Dolby Digital Selected with a sample rate of 48kHz.

    The default device is the A40 headphones. The speakers show not plugged in therefore I cannot set the sound to Dolby 5.1. If I plug the headset straight into the front 3.5mm jack on the motherboard I can set the 5.1.

    Anyone else have this issue? Am I doing something wrong or not?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •