Astro Professional Gaming Headsets & Bags

Astro Global

Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: A50 Mic fades in and out

  1. #1

    Default A50 Mic fades in and out

    When I am using my A50 Mic with my Xbox the people that I am talking to keep telling me that my voice keeps fading out and then coming back in really loud again.

    When I record my voice onto my PC there is no noticable fade in or out.

    What could be causing this?

  2. #2
    Join Date
    May 2010
    Location
    South Carolina, USA
    Posts
    8,271

    Default

    If possible, try using a different controller.

  3. #3
    Join Date
    Nov 2012
    Posts
    2

    Default

    I have the same problem too. Latest firmware, tried new cords, resyncing, new controllers and still have the same issue. Headset seems to work fine other than the mic with xbox360. Don't use it for ps3 or PC. My A50 is brand new and just received it from astro gaming yesterday.

    I thought this might be the same issue with the capacitor in the earlier wave of headsets but thought all new ones shipped had this fixed?

  4. #4
    Join Date
    May 2012
    Posts
    25

    Default

    This is just how all the new Astros work (A50's and the 2013 A40's). It's a design flaw that they haven't admitted to yet. No one is sure whether it can be fixed with a firmware update or not either. Your best bet is to return them and wait till they address this issue.

  5. #5
    Join Date
    Nov 2012
    Posts
    2

    Default

    I submitted a support ticket on this and am waiting for a response. Anyone else have this issue? The mic is basically unusable since it goes in an out

    I guess if I don't hear back from support in a few days I'll return it. It's a shame cause I really was looking forward in using the a50

  6. #6

    Default

    I bought these in America while I was on holiday, but I live in the UK.

    I wonder if I would be able to swap them for the older A40 edition if it can't be fixed? The headset itself is awesome but the mic is killing it.

  7. #7
    Join Date
    Nov 2012
    Location
    Denmark
    Posts
    6

    Default

    Quote Originally Posted by dannovision View Post
    This is just how all the new Astros work (A50's and the 2013 A40's). It's a design flaw that they haven't admitted to yet. No one is sure whether it can be fixed with a firmware update or not either. Your best bet is to return them and wait till they address this issue.
    Wait, what?! It's effecting every single one of them? What a joke.

  8. #8

    Default

    I have the same problem (though mine is with the A40), here is what support told me:

    "Hi Jason,

    There is a noise gate in the A50 headset that keeps outside noise from being transmitted through your mic. Depending on how loud you speak there may be some fluctuation in your voice. The noise gate is set fairly high (which allows the mic to work on multiple platforms), meaning that some fidelity is sacrificed, this is most noticeable on PC.

    You may need to move the mic a bit closer to your mouth a talk just a bit louder in order to keep from fading or getting cut off.

    Later this week (possibly today) we'll be releasing a new firmware update that should improve your mic levels as well. If the firmware update does not help, please let me know. You can update yur firmware here: http://astrogaming.com/firmware?nocache=adfa12

    Also, in a few months, we'll be launching a new version of the firmware updater that will allow you to adjust the noise gate level to work best with whatever platform you're gaming on."

  9. #9
    Join Date
    May 2010
    Location
    South Carolina, USA
    Posts
    8,271

    Default

    Quote Originally Posted by Mr Ginja Ninja View Post
    I bought these in America while I was on holiday, but I live in the UK.

    I wonder if I would be able to swap them for the older A40 edition if it can't be fixed? The headset itself is awesome but the mic is killing it.

    Please make sure that you have the latest firmware applied on your A50: http://www.astrogaming.com/firmware

  10. #10

    Default

    Quote Originally Posted by ASTRO refraxion View Post
    [/COLOR]
    Please make sure that you have the latest firmware applied on your A50: http://www.astrogaming.com/firmware
    I have the latest firmware. The party is still reporting fading and sudden bursts of noise.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •