1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird sounds in left speaker. A50 Gen 3.

Discussion in 'Community Support' started by smawllz, Feb 8, 2019.

  1. smawllz

    smawllz ASTRO Private

    So I made a post about sending my Astro A50 Gen 3 back to where i bought it because of the left speaker making a weird reverb/tin sound, like distorted, they sent it back saying there is nothing wrong with it. I know that there has to be something wrong because my right speaker sounds fine, and whenever a sound is on the left like shooting or cars driving by it sounds weird and makes me cringe at how weird it is, that shouldn't happen if there was nothing wrong with it. It's not like what people say about not being used to the surround sound because as I said it sounds fine on the other speaker, but for some reason the left just isn't right. Is there anything to do about this, like a fix or something? Thanks.
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey smawllz,

    If you flip the headset around so the left driver is now on your right ear, does the problem also follow or stay on your left ear?

    - Mitch
  3. smawllz

    smawllz ASTRO Private

    It does stay.
  4. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey smawllz,

    In this case, there cant be an issue with the headset as if the problem was with the left driver, it would now be heard on the right side. As you're still hearing this on the left with the right driver, it could be down to your hearing or how you are perceiving surround audio.

    - Mitch
  5. smawllz

    smawllz ASTRO Private

    Sorry I meant that it does stay in the left speaker, my hearing is fine. lol
  6. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey smawllz,

    Sorry for the misunderstanding there.

    Have you contacted our support team back to let them know that the issue is still there, you have tried flipping the headset around for example and the audio issue moves with it?

    We would like to probably look into troubleshooting your setup more just in case this is being caused locally by your console for example.

    - Mitch

Share This Page