1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Very bad Audio quality

Discussion in 'Community Support' started by FelipesGhost, Oct 11, 2016.

  1. FelipesGhost

    FelipesGhost ASTRO Private

    I have a white MixAmp pro tr and A40 tr headset that I purchased to use with my Xbox One S. My problem is that I get very echoe staticky sound through the cans and it is specially noticible with the system navigation sounds on the Xbox. Now I've doubled checked that everything is plugued in right and settings have been switched so they are set up for the mixamp. Everything is set up according to how Astro's website advices. I have also used different USB and digital optic audio cables and, also tried on a different xbox one console, and still get the same results. Has anyone else had this problem? And if you did, is there a way to fix it? I have the PS4 versions of the headset and mixamp by the way, and they sound amazing. Nothing like the xbox versions
  2. Ghost Officer

    Ghost Officer ASTRO Private

  3. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey FelipesGhost,

    How does your A40 TR Headset which you use on your PS4 sound when you connect it to the MixAmp Pro TR on your Xbox One? There is no difference between our A40 TR Headsets other than the colour so it would allow you to test whether it's the headset or the MixAmp that seems to be causing the problem.

    - Mitch

Share This Page