1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Regarding Firmware Update Headset: 24327.42 Base station: 24246.42

Discussion in 'ASTRO Nexus' started by fryerlawrence, Sep 29, 2017.

  1. fryerlawrence

    fryerlawrence ASTRO Private

    To: Astro Vertigo (a.k.a. Mitch) Perhaps you can assist with this issue.

    I gave up one of my gaming nights after I got off of work to fiddle around with my Astro A50 Gen 3 headset, because I was tired of my gaming buddies all chiming in at once saying that I sounded like a robot. This happens at least 2-4 times a day. The only remedy was to power cycle the headset. Firmware version: 19144.41 headset and 19146.41 base station.

    On my new quest to see if there was a new update, it took me the better part of last night; 2 HOURS before I gave up and went to bed, and almost 2 HOURS this morning to figure out how I could update my firmware on the base station and headset. After quite a long time of searching the threads I knew that there was a new update, Headset: 24327.42 Base station: 24246.42. What really frustrated me is:

    Release date: Date available on ACC
    Version: Version available on ACC


    WTH? I mean what does ACC stand for anyway???? Can't someone take 2 dam seconds to input the above numbers Headset: 24327.42 Base station: 24246.42 to the firmware support section so that it doesn't read: Release date: Date available on ACC Version: Version available on ACC! I tried a never ending Google search for that too and began to question my sanity.

    For some unknown godly reason, the Command Station, only after trying the below methods, I saw that it did recognize that there was an update available; but then get this I accidentally jostled the headset on the Command Center and I lost that prompt. (Yosemite Sam explitives inserted here: #$&@^&....!#@^!%&^!#$% ) After that I was treated like a red-headed step child and the Command Center would not recognize an update. I tried everything:

    1. Power Cycling the headset
    2. Uninstalling and re-installing the Command Center
    3. Hard resetting the headset
    4. Un-ticking and re-ticking the choices for the Command Center to Automatically check for new updates then closing the Command Center and re-opening the Command Center several times

    FINALLY! I was able to find this post: http://forums.astrogaming.com/index...here-to-keep-track.331481/page-22#post-702796

    Someone took the time (thanks @AtomicFlange!!!) to share on Dropbox, the newest firmware version.

    Mitch, you are only the messenger. I get that. But I am here to say for myself and possibly others:

    1. Why in the hell does it take more than 4 hours to find all of this stuff out?
    2. Why can't Astro Support make things easy to know what firmware version we are installing, from the start??
    3. Why do they have to let a website section be ambiguous?

    It takes two minutes, TOPS!, to put some data entry information onto a website if you know what you are doing.

    A final question I have is:

    If I am having trouble with the Command Center recognizing that there is a new update:

    1. Do I need to do a warranty exchange to fix the problem or

    2. Will the Headset: 24327.42 Base station: 24246.42 fix this problem.

    Thanks for letting me get this crap off of my chest. Astro deserves this rant right now.

    - Larry
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Larry,

    On the firmware page which lists the ACC, there should be a link to actually download the ASTRO Command Center. The reason we can't list the firmware on the website is because of how often it was changing and it made sense to have it update through the ASTRO Command Center instead, with that being our centralised software for the A50 Wireless and Base Station and MixAmp Pro TR.

    If the ASTRO Command Center is not prompting you for a firmware update, it is normal. We are aware and can offer the firmware for a manual installation.

    I would try updating to the latest firmware first and seeing if it corrects the problem. If it does not, we can troubleshoot from there.

    - Mitch
  3. fryerlawrence

    fryerlawrence ASTRO Private

    Mitch,

    Thanks for the reply.

    I did download the Command Center update from the link provided on the website today. As per that link right now, it only offers the 19144.41 headset 19146.41 base station update.

    I get no prompts for the new update whatsoever and I tried everything.

    Is it it a moot point if I already have the Headset: 24327.42 Base station: 24246.42 update via a runaround workaround?...lol

    Also important note... why not offer a manual update link automatically on the website either? Why do we have to jump through hoops if we kind of know what we are doing to install a manual update?

    This would have saved a TON of trouble.

    Also, paying $300.00 for a premium headset, there should be no issues with the Command Center not recognizing fairly instantly when there is a new update. To me that is again... more hoops to jump through. This should be easy. Not hard for customers who pony up their hard earned dollars and are loyal Astro A50 users.

    Please advise?

    Thanks,
    Larry
  4. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Larry,

    The reason we don't offer a manual firmware file is that the ASTRO Command Center should be pulling it automatically. At the moment, it is not, but we are able to offer it for manual installation over the forums or through our support team.

    - Mitch
  5. Theceige30

    Theceige30 ASTRO Private

    I just got these headphones today, and I'm prolly that angriest and most frustrated person on this earth. 300$ and I can't get the audio and game sounds to balance. Each button lowers or increases both. Then I hear all this talk about ACC and there isn't any updates there and nothing works. This is a hellava mess for 300$ headsets. i have the same firmware as above 24327.42 and 24246.42( my ACC version is 1.0.170). Please don't make this a waste of money. Thanks.

    Ceige
  6. Theceige30

    Theceige30 ASTRO Private

    Sorry this is for ps4 Wireless Astro A50's.
  7. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Ceige,

    Your firmware is the latest version. If your mixer is acting as a master volume then you have an incorrect setting on your console. Please open a thread in our Community Support and I will be able to assist you.

    - Mitch

Share This Page