1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ps4 A50 no longer charging

Discussion in 'Community Support' started by Matt Anderson, Dec 5, 2018.

  1. Matt Anderson

    Matt Anderson ASTRO Private

    So I've had my ps4 a50 for about 2 years now. I've rarely had an issue with the charge station not charging the headset right away. I would typically just hard reset the headset and all would be fine. Last night though I finished a gaming session, about 2 hours .. minimal battery drain on the set and when I went to put it on the base it did nothing. The headset light will not light up to show its connected to the base. The headset turns on, works. Same with the base. I tried resetting the headset a few times, unplugged all cables from the base station. Used a new usb and even switched it to PC mode and hooked it to my PC to see if that would kick start it. I applied the latest version of software for the base but the headset software will not update, obviously because it won't connect to the base. Im at the end of all my attempts and would hope someone could give me some help. I also created a ticket with support but have very little faith after seeing all the negative through the forum. I am willing to just buy another base station.... if that's my problem. I just want to make sure and exhaust all available fixes before I dump another 100 bucks. I love my headset and don't want to have to change
  2. One_Liter

    One_Liter ASTRO Specialist

    The same has happened to me, a few times actually. I just lay the headset off the station for the night and everything is fine the following morning. Battery is completely empty, according to the base station, but that's it.
    Matt Anderson likes this.
  3. Matt Anderson

    Matt Anderson ASTRO Private

    so I tried this , letting it stay off the basde overnight. According to the power light and the base....it still has power. its been off the base and powered on for 24 hours now. the base shows 3 bars. since it wont connect to the base via pc i cant see what it really is. I thought maybe it was a base problem so I went ahead and just purchased another base. It was not the problem apparently. It doesnt not connect tot hat one either. I have notice that when
    I try to hard reset the headset it is acting funny. It doesnt auto reset, powercycle , itself . i can hold it forever then let go and the light will go off. if i touch any other buttong it just lights up like nothing happened. I running out of options it seems and the support isnt helpful at all. My last email back simply stated " try removing the ear pads" that was it. Any help would be great . they were perfect until this random thing. I fear now i will have to purchase another set from another brand
  4. One_Liter

    One_Liter ASTRO Specialist

    I'm not 100% sure but I think that's how the reset works on this headset. You hold the Game and Dolby buttons and then the power light will go off and once you release the buttons the light will come back on. That's how I've been doing it, at least. Either way it sucks that it's not working for you. I know it's easier said than done but if you can bare in there I'm sure @ASTRO Vertigo will chime in here soon enough and help you out as much as he can over this forum. Good luck.
  5. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Matt Anderson,

    In it's current state, can it make any connection to the A50 Base Station to receive audio or are the two completely separated?

    - Mitch

Share This Page