1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[PC] A40 not recognized

Discussion in 'Community Support' started by Siranha, Feb 10, 2015.

  1. Siranha

    Siranha ASTRO Private

    A problem I've searched for everywhere. Typically the problem is solved by switching USB ports but, not for me. It's able to see that it's a Mixamp Pro, but unable to find drivers for it, and does not show in sound devices. I've tried all my ports (which have no problems with any other device I've plugged in), and I've tried 2 different mini USB cables, to no success. That potentially leaves the problem being the mixamp pro itself (which works very well on my ps4) or my OS (Windows 7; works for every other device I've tried). So I'm really at a standstill.

    I've tried deleting/uninstalling the mixamp itself, and reconnecting it a dozen times, to no avail, so I don't know what to do at this point. I'll leave a link to the image of the model I have.

    [​IMG]
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Siranha,

    The drivers are built into Windows which is why you can't find them online.

    If the MixAmp is working fine on your PS4 and is showing up under the chat options then I have a feeling it's somethign to do with Windows. Under the Playback and Recording devices, have you checked to see if you have accidentally disabled it and selected the option to hide disabled devices?

    - Mitchell
  3. Siranha

    Siranha ASTRO Private

    Yeah, forgot to mention, I'm able to view hidden/disabled devices, but astro mixamp is not among them. I'll test on another computer and update you on that.
  4. PsychoHorak

    PsychoHorak ASTRO Private

    I have the exact same problem! Have you managed to find a fix?
  5. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi PsychoHorak,

    Have you tried testing on a different computer?

    - Mitchell
  6. PsychoHorak

    PsychoHorak ASTRO Private

    Yes I have tried on my mac, and the problem persists.
  7. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi PsychoHorak,

    How about testing a different USB cable from the MixAmp to your computer?

    - Mitchell

Share This Page