1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Astro A20 wont turn on

Discussion in 'Community Support' started by Albert Torres, Nov 6, 2017.

  1. Albert Torres

    Albert Torres ASTRO Private

    I been having some trouble with the ASTRO A20. i just bought the ASTRO A20 an dnow they wont turn on i shut the off then when i went to turn it back on it dont turn on. Can someone help me how can you hard reset the A20 because it not the same as A50
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Albert Torres,

    I believe the hard reset is holding down Game and EQ together but I need to confirm this with our support team.

    Do you see any light activity if you plug in the headset using a USB cable? It may be low on battery.

    - Mitch
    tommygee34, shaneAKAbarry and Zeidy like this.
  3. Zeidy

    Zeidy ASTRO Private

    This worked for me! Thanks!
    shaneAKAbarry likes this.
  4. shaneAKAbarry

    shaneAKAbarry ASTRO Private

    Same issue. Not sure why this happened but this corrected my issue as well.
  5. Joshua010303

    Joshua010303 ASTRO Private

    Same thing happened to me
  6. KhalidGravi

    KhalidGravi ASTRO Private

    same thinks happend with mine but it can't turn on even with reset!! what to do now?? some one help please!!
  7. KhalidGravi

    KhalidGravi ASTRO Private

    wow thank you it actually worked I was doing it wrong thanks guys :)
  8. Juan Gonzalez

    Juan Gonzalez ASTRO Private

    I’ve tied this and they still won’t turn on. Any other things I can try?
  9. Novocainicorn

    Novocainicorn ASTRO Private

    How long should I be holding the Game and EQ buttons before this works? Because it doesn't seem to be helping me. And I am certain that I have the right buttons(Game just above the Volume scroll wheel and EQ above the Game and beneath the Power). Headset still refuses to turn on, And I am not getting a yellow light when I plug in the charger, though the light on the little pack is flashing as though it is registering the headset. HALP! TTnTT
  10. tommygee34

    tommygee34 ASTRO Private

    The game button is the one below the scroll wheel.

    I was having trouble myself, but I just got mine working again!
  11. AdmnInferno

    AdmnInferno ASTRO Private

    Hi,

    I have the astro A20 headset and for some reason when i plug in my box or transmitter into my ps4 with a usb the light on it doesnt turn on and it doesnt work but it works on every other device such as my computer. the light turns on and i have audio but not on my ps4. Any suggestions?
  12. AdmnInferno

    AdmnInferno ASTRO Private

    Also forgot to add, when my ps4 is off it has the light on but when o turn it on it seem the power is cut
  13. Tommie

    Tommie ASTRO Private

    The fix worked for me ;)

    My headset has been working fine for months. This only happened when I wore earbuds underneath the headset.
    I think coming into close contact with magnets may be the cause.
  14. Gerb

    Gerb ASTRO Private

    my A20 will not reset any more .I have tried everything A20 2017
  15. dr.ty

    dr.ty ASTRO Private

    I can confirm that i had the issue where my headset would not turn on (also would not go orange when charging although the dock would flash indicating charging the headset) and the solution of holding the game button and the EQ button (button below power) at the same time until the light comes on has solved my issue. thank you and i hope this helps others

Share This Page