1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Astro A10 Microphone not working (Xbox One)

Discussion in 'Community Support' started by ElDecano, Jun 4, 2018.

  1. ElDecano

    ElDecano ASTRO Private

    Seems like this is the umpteenth topic on this subject but here it goes:

    Sound works just fine, but the microphone doesn't. This is on the Xbox One and the headset was plugged directly to the controller. Tried a few different settings, restarting console, plugging back and making sure it's connected firmly, etc. nothing worked. Funny thing is my cheapo $20 Turtlebeach wired headset (which also plugs into the controller) works just fine so I know it's not an issue with my Xbox controller or console.

    Returning the headset (bought through Amazon) and considering buying another unit from Best Buy and give it a whirl again since the headset is very comfortable and the sound is very good for the price.

    Hopefully this thread encourages this issue to be investigated and taken more seriously.
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey ElDecano,

    Usually, this is caused by the cable side connecting to the headset not being in enough. It often makes a click, but there is a small gap between the 3.5mm connector and the headset port and the cable just needs to go in a bit more. If you do run into any other issues with your second unit, please contact us over the forums or through our support team. I'm sure a little bit of troubleshooting will get you up and running in no time.

    - Mitch

Share This Page