1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A50's won't turn on

Discussion in 'Community Support' started by Landon Rasmussen, Dec 29, 2016.

  1. Landon Rasmussen

    Landon Rasmussen ASTRO Private

    I have had these Gen3 Astro A50's for less than a week. Today is the 29th, and I bought them on the 24th of December. The headset will not turn on even when plugged directly into the USB port, and will not draw a charge from the charging station. The charging station is communicating how much charge is left in the battery, but the headset will not turn on or charge.
  2. Ross1004

    Ross1004 ASTRO Private

    I had the same problem. I left the headset off the base station with the power button in the up position for 2 days. Then put them on to charge and it fixed itself.
    Was in the process of sending them back but I thought I would try it one last time and it work.
    Just hoping that they are now fixed.

    Hope this helps
  3. agustin

    agustin ASTRO Private

    just do a hard reset on them when ever it does that ...hold down the Dolby button and Game side of the Game/Voice paddle on the right ear cup. :)
  4. Death-_-Doctor_

    Death-_-Doctor_ ASTRO Private

    i am having the same problem with mine.. i have tried doing the hard reset and nothing they still will not power back on..... i see the base is responding to the headset because when i press the Dolby button it will go on and off when i press that button..
    i have tried the hard reset 3 times now and still will not power on..when i do the hard reset i am waiting for 30 sec and when i put them back on the base the only thing that is on is the lightning bolt and it will flash 3 times then goes solid.
    the computer app says the battery is backat 100%
  5. Ryan Casey

    Ryan Casey ASTRO Private

    I literally made an account for this forum just to thank you for this handy little trick
  6. Capafella

    Capafella ASTRO Private

    AGUSTIN >>> To anyone having problems like this with this TOP OF THE LINE UNIT, DON'T PANIC. 99% of the time a HARD RESET fixes all. - 1) Turn off headset. 2) Hold down the Dolby Digital 7.1 button + The "Game" side button on the right ear cup. *Hold for 15 seconds or until LIGHT TURNS ON. This has fixed my headset everytime when thus problem occurs.
  7. Drustan Stabat

    Drustan Stabat ASTRO Private

    I know this is a super old post, but this tip just helped me out so immensely I made an account to thank you, so thank you random internet god.

Share This Page