1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a50 headset won't turn on.

Discussion in 'Community Support' started by Kixwutube, May 23, 2014.

  1. Kixwutube

    Kixwutube ASTRO Private

    I've just recently bought a pair of a50s. There were so many problems with them it would take me a while to type it all but then they just flat out wouldn't turn on. So I had to send them back for evaluation. When they finally got back to my house they still didn't freaking work I'm getting very frustrated because I've got use them a total of 1 day when I bought them last month. If anyone could help me that would be great because I'm about to get really angry.
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    What happens if you connect the USB cable to your A50 Wireless Headset, does it still not turn on? Also what is your support case number please so I can take a read through it and see what we did to repair or replace your headset.

    - Mitchell
  3. Kixwutube

    Kixwutube ASTRO Private

    I've had multiple cases but the largest one is #2121 nothing happens with the headset. It won't turn on, it won't charge, it won't turn on while the USB is connected, it won't turn on when connected to my PC, and won't be detected for firmware updates. Thanks for trying to help.
  4. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    Support case #2121 isn't related to the issue you are experiencing and doesn't mention anything regarding you sending your equipment in. It's also been closed.

    Do you still have the support case number for when you sent your equipment in?

    - Mitchell
  5. Kixwutube

    Kixwutube ASTRO Private

    My mistake try case #2602
  6. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    I've checked all the notes on the system and can see we replaced the A50 Wireless System so it's strange that the exact same issue has happened again. I can also see the reply back to Kevin through this support case and I would suggest awaiting a response back so we can continue troubleshooting and figure out what's happened. I'm sorry for the inconvenience this is causing you. Please let me know if I can be of any further assistance.

    - Mitchell
  7. Kixwutube

    Kixwutube ASTRO Private

    I don't understand either, it came back, I charged it for around 2 hours before going to dinner I came back to use them and they didn't work. :( I just want to be able to use the headset I payed so much for.
  8. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    Is the A50 Wireless Headset being charged through the transmitter? If so, what is the A50 Wireless Transmitter being connected to?

    - Mitchell
  9. Kixwutube

    Kixwutube ASTRO Private

    Yes it was being charged through the transmitter connected to my Xbox one
  10. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    I'm wondering if it's a battery issue and something such as a power surge has damaged it as you mentioned it was working fine until you started charging and then it stopped working. Other than that, I don't really have any other troubleshooting as if you are unable to power on the headset with the USB cable, it will probably need servicing once more by our support team. I'm sorry about this inconvenience.

    - Mitchell
  11. Kixwutube

    Kixwutube ASTRO Private

    :( thanks anyway
  12. Kixwutube

    Kixwutube ASTRO Private

    I think we can rule out a power surge because they didn't stop working until I unplugged them from the charger
  13. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi Kixwutube,

    Thanks for letting me know. Probably not a power surge then if it was still active.

    - Mitchell
  14. Martin Blake

    Martin Blake ASTRO Private

    Hi

    im having the same problem but i wasnt charging anything and had no wires connected to it?
  15. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

  16. RetraC

    RetraC ASTRO Private

    I am also having this problem. I've had mine since September of 2013 with no issues until today (February 2015). They worked before I went to class, come home an hour and a half later, and all of a sudden they don't turn on. I have no LED light or anything. The MixAmp seems to be working fine. But the headset seems to be dead. (as in dead, dead)
  17. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi RetraC,

    I have responded to your thread here - http://forums.astrogaming.com/index.php?threads/astro-a50-not-turning-on-pc.82737/

    Thanks,
    - Mitchell
  18. paul12987

    paul12987 ASTRO Private

    hi am having thr same problem was just using mu a 50s they was working fine then the battery ran out I went to charge them and nothing no lights nothing the won't turn on or anything but the power box is fine not sure what I can do to get this sorted could someone plz help me
  19. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hi paul12987,

    Could you try a different USB cable to charge your A50 Wireless Headset such as the one being used between your console or computer and your A50 MixAmp TX?

    - Mitchell
    soxfan143 likes this.
  20. Dirtslinger89

    Dirtslinger89 ASTRO Private

    I'm having the exact same issue as well, I have always only charged through the transmitter (connected to my Xbox One) using only the provided USB-Micro USB Cable and it got to where my battery would hold less and less of charge every time I used them it seemed like. When I plug my charging USB from the Tran. into the A50 Headset my trans. totally loses power and all the lights go off and it shuts completely off, unplug the charging usb from the headset and the trans. comes back on and it works just like it's supposed to again. This whole trans. power loss/shut down thing just started happening after the headset died completely the very last time about 2-3 weeks ago and wouldn't take a charge what so ever. I've only owned mine since October 2015,really wanted a set with the mixamp but I was ignorant of the brand and their products ands thought thsee came with the mixamp until I got them home and unboxed them. To be completely fair I just opened my warranty case today, I'm hoping to find a way to resolve this issue that is mutually beneficial for Astro and myself, atleast for present and future purchases anyway. I definitely wish now that I would've taken them back and exchanged them for A40 series with a Mixamp. So much money for these, very comfortable but right now just paper weights for me.

Share This Page