1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A50 Gen 4 charge problem

Discussion in 'Community Support' started by h3isenberg, Dec 2, 2018.

  1. h3isenberg

    h3isenberg ASTRO Private

    Hey y’all.

    I have an issue where the headset charges very strangely. It would charge to full and if I turn the console on the next day, it would be at 3 out of 4 bars charged. I charged it the other day fully and last night I turned them on to play and were completely dead. It’s like it can’t hold a charge when they’re turned off? These are my replacements that I got months ago too.
    Last edited: Dec 3, 2018
  2. h3isenberg

    h3isenberg ASTRO Private

  3. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey h3isenberg,

    What firmware is currently running on your headset and have you tried a hard reset?

    - Mitch
  4. h3isenberg

    h3isenberg ASTRO Private

    Hi.

    No I haven’t tried a hard reset. How is that done again? (Sorry). Also, I’m not sure what the update version is. If a new one came out recently then I haven’t updated. I got these about 4-5 months ago and had them plugged in the first day but not since. Could a ln update fix something like this? Thank you.
  5. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey h3isenberg,

    It can sometimes depending on which firmware is currently installed.

    To perform a hard reset.

    Make sure both your A50 Base Station and A50 Wireless Headset are switched on. Hold down the Dolby button and the game button on the mixer paddle for up to 30 seconds until the lights on the A50 Base Station except for the lightning bolt disappear. Release these two buttons and wait for the headset to reconnect to the A50 Base Station which is indicated when all of the lights come back.

    - Mitch
  6. BionicTbag

    BionicTbag ASTRO Private

    The largest complaint I believe I could levy is that my A50's need a hard reset every few day...as they lose the connectivity somehow and wont allow mic in game. a hard reset works every time...

Share This Page