1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A40TR Mixamp disconnecting from PC

Discussion in 'Community Support' started by Flybyderp, Nov 9, 2018.

  1. Flybyderp

    Flybyderp ASTRO Private

    I've tried every USB port on my PC and it still disconnects.

    I'm on the latest firmware, I've even tried rolling back the firmware to no avail.

    I have also done the USB selective power disconnect change from youtube videos and nothing seems to work.

    OS Build: Windows 10 Professional (17134.376)

    Privacy settings in the support thread are also set correctly. This Mixamp has been RMA'd once before.

    All drivers are up to date as well :(

    When it disconnects I can't hear people talking nor does my mic work. Audio from games and such still come through.
    Last edited: Nov 9, 2018
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Flybyderp,

    Do you have any overclocks enabled on your computer? And what other USB devices are currently connected to your computer?

    - Mitch
  3. Flybyderp

    Flybyderp ASTRO Private

    Overclocks yes, all stable CPU wise, though I suspect it might be due to RAM stability which has been iffy since updating my bios on my Gigabyte mobo (Ryzen).

    Usually this is what happens, I'll be playing and I'll randomly get a stutter lag and that's when the Mixamp disconnects from voice channel completely and I have to restart the mixamp power.

    Rival 600 Mouse
    CM Quickfire TK Keyboard
    Internally on USB - Corsair Liquid Cooler

    UPDATE: Just finished running stability testing all night for RAM and CPU, everything is stable. Out of ideas at this point. (6AM)

    Update 2: Disabled my overclocks all together, still disconnects.
    Last edited: Nov 12, 2018
  4. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Flybyderp,

    What is the model number of the GIGABYTE motherboard?

    - Mitch
  5. Flybyderp

    Flybyderp ASTRO Private

    Gigabyte AB350 Gaming 3

    It may be a bios issue, I've reverted back to bios F22 with the same overclock settings as before and haven't had a disconnect yet. I'll keep y'all updated.
    Last edited: Nov 12, 2018
  6. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Thanks for the update, Flybyderp.

    What did the latest UEFI update address as it may be related to the USB ports dropping audio devices. I am using a GIGABYTE AORUS board myself so it's odd to see this happening with these sets of motherboards.

    - Mitch
  7. Flybyderp

    Flybyderp ASTRO Private

    Not entirely sure, F23 bios was an Agesa update, but I've read of people having nothing but issues on it compared to F23D (Beta version of that same bios I was originally on, think my Amp was fine on that bios TBH), F22 was an older version that most people found to be more stable, though it just crashed on me.

    Need to go find the F23d bios and go back to those as they had everything stable, but I just like keeping everything update lol.

    One guy in this thread was even having issues with his M.2 : https://www.reddit.com/r/GAAB350/comments/97jvuc/f23_stable/

    With F22 though my mixamp hasn't disconnected but my game did ha, guess this is where staying up-to-date isn't always the best route.
    Last edited: Nov 13, 2018
  8. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Thanks, Flybyderp.

    I'll make a note of this on our internal logs to help with future customers. Hopefully it's something GIGABYTE can work out and resolve. Looks to just be a bad BIOS rather than isolated to our products.

    - Mitch
  9. Flybyderp

    Flybyderp ASTRO Private

    Update: Buddy has a pair of A50s GEN3, his also disconnect on his Ryzen system, completely different motherboard. This might be an AGESA issue that AMD needs to be made aware of.

    His old headset (SS Arctis) never disconnected. o_O

Share This Page