1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A40 + MixAmp Pro TR Mic\Comms Randomly Stops Working [PC]

Discussion in 'Community Support' started by Aaron Morford, Jan 23, 2019.

  1. Aaron Morford

    Aaron Morford ASTRO Private

    There are a few older posts about this, but I haven't found a resolution, so I'm reposting.

    I have my A40s connected to the MixAmp and the Mixamp connected to USB for mic (using optical for audio so that's not an issue). Randomly, my mic will stop working and I cannot hear other people in voice chat (in game or Discord) so there is something going on with the "communication" part of it.

    I have uninstalled and reinstalled the driver. I have uninstalled and reinstalled Command Center. CC says my firmware is up to date. I have also tried turning off exclusive control and My Windows 10 privacy settings allow for mic usage.

    The only fix I have found so far is to switch the Mixamp to Console mode and then back to PC. I have to do this multiple times a gaming session.
    Playback.png recording.png
  2. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Aaron Morford,

    You shouldn't be using the optical cable, and this may be causing the problem. I would recommend disconnecting the optical cable, setting the ASTRO Game device as the default and then restart your computer to see if the issue continues to happen.

    - Mitch
  3. Aaron Morford

    Aaron Morford ASTRO Private

    Mitch,
    I'll definitely check this out when I get home, but just to clarify, is this guide deprecated because it says both?
    setupguide.png
  4. augustomacioni

    augustomacioni ASTRO Private

    I bought my astro a40 tr + amp mix and I have the same problem as you. I have already tried a number of methods and I have not had any results, I have already changed all the USB, I have already left the USB in the mode to always be connected, already tried to take of the USB 3.0 and use the normal, I do not know what else to do. I can not enjoy an experience with the handset because I try this annoying problem all the time
  5. Aaron Morford

    Aaron Morford ASTRO Private

    @augustomacioni If you ever find a solution, please let me know. I tried all suggestions so far. I gave up and bought a Yeti this weekend and am now using my regular studio headphones for now. I like the new setup a lot, but it's disappointing, considering the price of the A40 set and I bought custom pieces for the ears.
  6. augustomacioni

    augustomacioni ASTRO Private

    @Aaron Morford I tried everything and dont haved a solution. 2 days ago i reset all my pc system and instaled again e the problem look solved. You should try. Good luck bro
  7. ASTRO Vertigo

    ASTRO Vertigo Social Media Team Staff Member

    Hey Aaron Morford,

    Sorry for missing this post. This guide is for our MixAmp Pro GEN1 and GEN2 and does not apply to your MixAmp. Please refer to the instructions that came with your MixAmp.

    - Mitch

Share This Page