Recent Activity

Activity stream for all registered members at ASTRO Gaming Forums.

  1. A50 SW Battlefront replied to the thread ** I FINALLY have a good A50 Gen 3!! **.

    Hey London Fella, I completely understand your frustration and anger, but form my own experience it’s just better to return the damn thing...

    Feb 25, 2017 at 9:49 AM
  2. John Boggs posted a new thread.

    No sound on 100% game mix?

    I have a new A50 with a PS4. For some reason, the mix between chat and game isn't working. If I put the mix all the way to chat, I can...

    Forum: Community Support

    Feb 25, 2017 at 9:44 AM
  3. Ryan Casey replied to the thread A50's won't turn on.

    I literally made an account for this forum just to thank you for this handy little trick

    Feb 25, 2017 at 9:28 AM
  4. The London Fella liked SandmaN's post in the thread ** I FINALLY have a good A50 Gen 3!! **.

    Trust me, I've had the new A50 Gen 3 headset since the very day it was available and I've been doing exactly that and more. It doesn't...

    Feb 25, 2017 at 9:25 AM
  5. The London Fella replied to the thread ** I FINALLY have a good A50 Gen 3!! **.

    Dearest Mitch, So on top of all of my very evident issues, you have the audacity to call me a liar?!?! When I returned the headsets to...

    Feb 25, 2017 at 9:24 AM
  6. Imbo replied to the thread Astro a40 gen 3 party chat problem xbox one.

    Ps:I had the same peoblem for my last pair of astro a50. Also i tryed another usb cable (not from astro) and still no sound. *i cant hear...

    Feb 25, 2017 at 9:09 AM
  7. peterjohnson replied to the thread ETA on Basestation sale?.

    Mitch, 8 see that the Xbox gen 3 base station is for sale. Can you tell me when the PS4 one will be? Thanks!

    Feb 25, 2017 at 9:09 AM
  8. The London Fella liked A50 SW Battlefront's post in the thread ** I FINALLY have a good A50 Gen 3!! **.

    Well we might not have opened a support case with Astro, but we have posted the issues in all details including countless tests and...

    Feb 25, 2017 at 9:08 AM
  9. Imbo posted a new thread.

    Astro a40 gen 3 party chat problem xbox one

    Hello, I just bought a pair of A40 TRs for the XBox ONe / PC. On PC everything works fine. On XBox One, the sound works, but no sound from...

    1488042331623-1690317331.jpg

    Forum: Community Support

    Feb 25, 2017 at 9:06 AM
  10. SandmaN replied to the thread ** I FINALLY have a good A50 Gen 3!! **.

    Trust me, I've had the new A50 Gen 3 headset since the very day it was available and I've been doing exactly that and more. It doesn't...

    Feb 25, 2017 at 8:36 AM
  11. Bezbashni attached a file to the thread Astro Command Center.

    Hi! Here you go. Some screenshots below include the text that needs complete revision of translation. I can't fully understand it because...

    Безымянный.jpg Безымянный2.jpg Безымянный3.jpg Безымянный4.jpg Безымянный5.jpg Безымянный6.jpg Feb 25, 2017 at 8:31 AM
  12. A50 SW Battlefront replied to the thread ** I FINALLY have a good A50 Gen 3!! **.

    Well we might not have opened a support case with Astro, but we have posted the issues in all details including countless tests and...

    Feb 25, 2017 at 7:02 AM
  13. Mpuk replied to the thread a50 headset won't turn on..

    No idea it is the halo edition

    Feb 25, 2017 at 6:46 AM
  14. ASTRO Vertigo replied to the thread aftermarket headsets with mixamp pro?.

    Hey theoryyylol, It's possibly an issue with the MixAmp as you have suggested. Have you tried using a different USB cable between the...

    Feb 25, 2017 at 6:35 AM
Loading...